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Topic
Project-level Changes

Background

Most of Pisces’ functionality has been focused on the statement of work (SOW) and its associated data. With this
release more emphasis has been placed on the project including:

»  Granting write permission to contacts allowing more control of varying aspects of the project
»  Allowing the attachment/moving of documents
» Requiring a project lead

Discussion

While the majority of effort associated with a BPA Fish & Wildlife project is typically associated with one or more
contracts (in particular the development of a statement of work), the project describes the overarching goals and
objectives those contracts aim to achieve. Contracts are usually awarded on an annual basis, yet projects are
more commonly funded for three or more years. To effectively capture information that affects all underlying
contracts Pisces has been enhanced to address this need. Now, project sponsors will have the ability to identify
the non-BPA funding sources they identified during the proposal project, as well as associate joint deliverables at
the appropriate level.

Details

Granting write permission to Project Contacts

As with contracts, the BPA Project Manager can now explicitly grant contacts at the project level
permission to modify content. The assigning of write permission was critical so the Project Lead
could address Cost Share reporting. Additionally, in order to add a document to the project, the
user must have write permission.

Allowing the attachment/moving of documents

Jointly produced documents or those that affect all associated contracts may now be attached at
the project level. Moreover, documents previously associated to a single contract can be moved
to the project level; where appropriate. To add, edit, or delete a document, the user must have
write permission to the project. To move a document, the user must have write permission to
both the project and contract. Moreover, not all documents can be moved (e.g., Budget, Property
Inventory, and SOW Review PDF).

1. To attach a new document to the project:
a. Open the project (from My Stuff, right-click on a contract and select View Project) and then click
the Attachments tab.
. Click the Add button
c. Complete the fields in order as they become available. Carefully choose the attachment type.
Other aspects of the software check for the presence of specific attachments based on the type.

Note: The full dropdown list is now presented to help with the selection.

2. To move a document from the contract to the project:
a. If you're at the Attachments tab of the contract, right click on the document you wish to move
and select Move Attachment. The document will be automatically moved to the project
associated with the contract

Note: Every document has an associated author. If the author of the moved document is not on the
project’s contact list they will be added; but not removed from contract contact list.

b. If you're at the Attachments tab of the Project, first navigate to the Contract by clicking the
hyperlinked contract number. This will open the contract’s Attachment tab.
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c. Right-click on the document you wish to move and select Move Attachment. The document will
be automatically moved to the project associated with the contract.

Requiring a project lead

Related to Cost Share, each project must now have at least one person identified as the Project Lead. This
person will be the recipient of all notifications and reminders as pertaining to Cost Share as well as other
project relevant communications. It is the responsibility of the BPA project manager to add at least one
project lead to each project and grant them write permission.
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Topic
Cost Share

Background

The Fish and Wildlife Program must be able to identify and confirm the amounts and sources of cost share
funding for each of its projects.

Discussion

The new cost share data entry will enable our project sponsors to provide us with the most up-to-date
information. This is especially important for project work in areas of shared responsibility, where cost sharing can
demonstrate that BPA's funding is not supplanting that of (or “in lieu” of) another entity already authorized or
required to undertake the activity.

The new Cost Share tab will display the amount and source of cost share funding (if any) that a sponsor
identified during the project proposal process. We will ask sponsors to update this information once per year, in
late October.

After the close of each fiscal year, individuals identified as Project Leads in each Project Contact List will receive
auto-emails inviting them to confirm and/or update their cost share information in Pisces. Notifications will only
be sent for those projects that had a BPA approved budget for the previous fiscal year.

Guidance for entering cost share data, including a glossary of terms, will be posted at
http://www.efw.bpa.gov/contractors/reporting/costshare.aspx. BPA Project Managers will be available to advise
sponsors about how to complete this activity.

Details

The following is a description of the steps necessary for project leads. The only action necessary on the part of
BPA Project Managers is to click the Confirm button (located in the same place as the submit button in Figure 2
below). You will receive a notification that a cost share estimate has been submitted (this works similarly to
Status Report submissions).

To submit your FYO7 cost share open the project (not the contract). From My Stuff, right click on a contract and
select View Project then click on the Cost Share tab. Or using the new quick access tool click File->Open, type
the project number into the field and press enter. Then click the Cost Share tab.

Open Project/Contract

Enter the project number, contract number. or BPA

internal work statement number:

Cancel

Figure 1 (Quick Access dialog)
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The following screen is an example of the cost share tab for a project that included cost share as a part of its
FY2007-2009 BPA Fish & Wildlife Program proposal.

%' Pisces - [Project Details 1999-019-00 - Restore Salmon River, (Challis,]

%F File Beports Tools Window Help

: [E Save

-2 Xx

\Q‘-!] My Stff 4% Explore ,,.,2. Wildlife Areas fﬁl Contacts 9 User Accounts 3% Spelling ~

Add Funding Source,., | Add Itemn |

SUFErY | Map | Proposal | Budget | Status | Attachments

Use the table below to track this project's proposed and achieved cost share by fiscal year, See more on Cost Share Policies,

f Item / Fiscal Year

15 of Engire:

Type Likelihood Proposed

[ Feasibility Study

=l Feasibility Study, Construction

Fr2007 In-kind * ok x $1,700,000
Fr2008 In-Kind * ok ok $200,000
FY2009 In-Kind * ok ok $200,000
FY2008 Cash * ok $575,000
FY2009 Cash * ok $635,000

Total Prior Year (Mone):

Total Current Year (Y2007
Total Future Years (FY2008-2009);
Total:

Current Plan Status:  FY2007 Mot Subrmitted

$0
$1,700,000
$1,610,000
$3,310,000

Actual | Comment

$0
$0

$0

Subrnit, .

1999-019-00

Restore Salmon River (Challis,

Custer County Soil and Water Conservation District (SWCD)

Close

Mcclintock, Gerald

Figure 2 (Project Cost Share sample)

1. If your project included cost share, each Funding Source, Item, and Fiscal Year will be listed (as shown in
Figure 2). In the Actual column for FY2007 of each Item, enter the corresponding cost share. If no cost

share was realized, enter O (zero), do not leave the cell blank.

2. If the grid on the Cost Share tab is empty (because the project proposal did not contain cost share
information) AND your project did not obtain any cost share, you still need to click “Submit”.

3. If you received cost share where previously none was identified:

a. Click the Add Funding Source button, select an organization from the drop down list

Select the Funding Source.

Pisces - Add New Cost Share Funding Source

Funding Source: |

(Unspecified Org)
Local project sponsors

NES| KR

Advanced Telemetry Systemns, Inc.
Aer-Ex, Inc,

Alfred P. Sloan Foundation
American Fisheries Society, Oregon Chapt
Ametican Indian Science and Engineering

Alaska Departrnent of Fish and Game I

Figure 3 (Add Funding Source)

b. Click the Add Item, and a new line appears under the "Funding Source" just identified. Enter a

title that describes what the cost share was to go toward.

Click the Add Fiscal Year button (FY2007 will appear) and choose Cash or In-kind for the type.
Finally, enter the amount of cost share received.
For additional funding sources repeat steps 1-4, for additional items, repeat steps 2-4.

When you've updated all pre-existing cost share items and/or added new ones, click the Submit

-~ o Qo

button in the lower right corner of the screen. This will send an email to the BPA Project
Manager alerting them you've submitted your cost share data. When the BPA PM confirms
receipt of your submission, you will receive an email in return.
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Attachment Enhancements

Background

With the version 2.3 release on June 7, 2007, Pisces allowed the attaching of documents directly in the database,
including the complete transfer of more than 2500 Progress (Annual) Reports. Called Phase 1 by many, this initial
rollout of attachment functionality was only to be the beginning.

Discussion

In this release (version 2.4) Pisces’ management of documents has gotten a lot smarter. Enhancements include:

>
>
>

>
>

Project-level attachments (discussed above)

Supporting the attaching of documents to a specific work element during completion of the Status Report
Ensuring a Progress (Annual) report is attached to the appropriate work element when it is marked
complete

Preventing the attaching of duplicate documents

Adding a View button from the edit attachment screen

Details

Attaching documents to a work element from the Status Report

The contractor can now attach a document to a specific work element directly from the Status Report
(this is most handy for Progress Reports, since Pisces verifies that a report has been attached before the
status report can be submitted). But this is also useful for other types of deliverables (e.g., photos,
maps, etc.).

To upload a document to the contract and associate it with a particular work element, click on the add
attachment hyperlink. This displays the Attach Document dialog box. Follow the steps as they become
enabled, then click Upload. Pay particular attention to the Attachment Type.

Once the document is uploaded, a hyperlinked paper clip symbol appears on the work element title line.
Hover your mouse over the paper clip icon to see a tool tip showing how many documents are attached.
Click on the paper clip to view the attachment. If more than one attachment is present, a list of
documents will appear.

Pisces now checks that a Progress (Annual) Report is attached

When a contractor submits his/her status report and has marked WE# 132, Produce (Annual) Progress
Report as complete, Pisces verifies that one status report for each completed work element 132 has been
attached and associated to the appropriate work element. If no document has been attached, the Guide
will include a link to the “Add Attachment” dialog box so the contractor can upload their report.

If a Progress report was uploaded before September 20 and the contractor is now trying to submit a
status report, but is unable, please contact Fish Support. If the subtype of the report is Technical/Final or
Non-Technical Final, the contractor won't be able to submit the report. If the subtype is Technical/Draft
or Non-technical/Draft the contractor should edit the attachment and associate the report to the
appropriate work element.

Preventing Duplicate Attachments

Pisces will now check to ensure any document uploaded is not already attached within the same project
(this includes different contracts within the same project). Because Pisces now allows documents to be
attached at a higher level than previously (i.e., the Project versus the Contract), it is undesirable to have
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the same document attached to multiple contracts. Such a document should be attached at the project
and then only once.

Viewing a document from the Edit Attachment dialog box

Pisces now provides a simplified means of viewing a document once you've started to edit or view its
properties. From the Edit Attachment dialog click the View button in the lower left corner. This is
especially helpful if you're verifying information in the document that you need for the properties screen.
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Topic
Publication search enhancements

Background

Along with a new method of uploading documents, and therefore a new way of storing them, came the need to
better search the documents. The previous publications search database was only for documents that had gone
through the Department of Energy’s publishing process.

Discussion

More than 2500 Progress Reports are stored in the Pisces database, along with hundreds of other documents;
many of which contain valuable information and data that could be useful to other participants in the BPA Fish &
Wildlife program, not to mention the public at large. Finding the report most relevant to your needs has always
been difficult at best, impossible at worst. Changes in this release should make searching and therefore the
results much more useful.

Details

Click here to launch the publications search website. If the link doesn’'t work, copy and paste the following URL
into your web browser http://www.efw.bpa.gov/searchpublications/. You can also access the Report Center from
within Pisces. Click Reports>Report Center from the top menu. Figure 4 displays the new interface. Note three
dark blue bands. Clicking on any of them will display a new section and automatically collapse the open section.

Searching for any author, not just the primary author

This version of Pisces now allows you to search on any author, not just the primary author as well as a
full text search of the document; not just the title and/or description. From the search publications
website, (from within Pisces, click Report->Report Center from the top menu. Then click Search
Publications from the left sidebar). Enter one or more filter criteria (some are dropdown menus, others
allow free form text; e.g., Any Author). Click Search.

By Title, Description, Type, Author or Publish Date

Publications of type:
A4

Titles containing the word or phrase:
Descriptionsfabstracts containing the word or phrase:
Organization of the Primary Author:

Primary Authior: Any Author:

Date Uploaded:
{mmyyvyy]

Report Covers Dates:
to: {mm/ddfyyyy)

Search | Clear |

By Project or Contract

By Document ID

By Text in Documents
Figure 4 (Publications search interface)
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Full text searching of any web public document

Click the bar "By Text in Documents.” The following appears:

tin Documents

Full text search expression:

Use Google syntan for more specific searches, For ezample: "fall chinook" OR salmon

Search | Clear | powerﬁ; (;O'Jg[e“

Figure 5 (Full text search filter)

Pisces version 2.4

September 20, 2007

One limitation to this search is you cannot combine full text search with any other criteria on another

filter area. Searching is done exactly the same way as you would on Google™.
possible searches are:

A few examples of

sockeye salmon .
y necessarily together.

Returns all documents where sockeye and salmon are present, but not

"sockeye salmon" Returns all documents where the phrase "sockeye salmon” is found.

salmon -chinook

Returns all documents where salmon is present and exc/udes those where
chinook is present (note the minus sign in front of chinook).

OR sockeye) sockeye are present.

salmon AND (chinook Returns all documents where salmon and chinook or salmon and

fence and "barbed wire
present.

Returns all documents where fence and the phrase "barbed wire" are

juvenile salmonids -
chum

chum).

Returns all documents where juvenile and salmonids are present but
excludes any where chum are present (note the minus sign in front of
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Topic

Miscellanea

Background

As with any software application, often it is the small things that matter the most. With this release a few such
enhancements are being included.

Discussion
Details

Go Direct:

As you log into Pisces, you now have the option to go directly to a Project, Contract, or BPA Internal
Statement of Work (SOW) number.

W Lizer Mame: |gmcc|int3ck@bpa.gov Change Sethings...

Password: |* HAHER AL Change Password. ..
Go Direct: | {optional)
Problems? Email fishsupporbi@bpa . goy Close

Figure 6 (Login screen)

Using the following formats, enter a value and after clicking Login, provided the value is valid, Pisces will
open the corresponding project/contract to the Summary tab.

» Enter a project number including all 9 digits (e.g., 2008-123-00, or 200812300)

» For contract numbers do not include the leading zeroes (e.g., 35459 not 00035459)

» For Master or Blanket agreements, include the release number after the contract number
separated by a hyphen (-). The release number must have its leading zeroes (e.g., 652-00004).

Quick Access

Once you're logged in, you may need to quickly access a project or contract that isn’t in your My Stuff.
Of course you could always open Explorer, but a much faster way is to use the new Quick Access tool.
Press CTRL+O or click File>Open and the following dialog box appears.

Open Project/Contract

Enter the project number, contract number, or BPA

internal work. statement number:

Cancel

Figure 7 (Quick Access dialog)

The search supports the same formats as the login screen above.

Most Recently Used

Like with most Windows® applications, you can open files you've recently accessed. In Pisces there are
two sub-areas, Recent Contracts, and Recent Projects under the file menu. Keyboard shortcuts are
supported. Just press the underlined number corresponding to the Contract/Project you want to open.

¥ Pisces - [Pisces - My Stuff]
File | Beports  Tools  Window Help

B My S &8 Explore of] Wildlife Areas () Contacts 9 User Accounts 9% Spelling -
R it
¢ Refresh F5
= Erint Cul-F following contracts, If you see red, there’s a good chance you need to take some action,
T My St Cirl+h
&% Explare Chl+E
Id Mcclintock
4 Widlife Arszs  Cil+w _
rart Title Status | Fnd Date [FC Comnlete | Cur. Staty
Fecent Contracts 4 1 CR-91954 - 20016200 EXP FALISPEL TRIBE COORDINATION
Fecent Projects C 2: BPA-003095 - Conservation Easements
Log outand close 3 25270 - 1996-067-00 EXP MANCHESTER SPR. CHINOOK CAFTIVE BROODETOCK

4 6116-1993-019-00 RESTORE SALMOM RIVER AREA - CEWCD
532493 - 199901900 EXP RESTORE SALMON RIVER 12-MILE REACH CHALLIS. 1D

Figure 8
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The number of contracts and projects listed is a user-definable option. Click Tools=>Options. On the

Preferences tab list the number of contracts and projects you'd like to list (minimum of 5 maximum of
20).

%' Pisces Options
l Iy Suff ] Explorer ] Connection ]

% Custamize how Pisces starts up and behaves.

Starkup
Username: |gmcclintc-ck@bpa.gov
Default Startup Window: |M5" Stuff ﬂ
Speling
Iv show spelling errors as you bype [™ Ignore words in UPPERCASE
Prompts

Iv Remind me when Pisces automatically adds default milzstones

Hiskary

# of recent contracts |2 EI: # of recent projects  |g El:

Figure 9 (Pisces Options screen)

Progress Report Title

The title field for uploading a progress (annual) report has been increased from 100 to 200 characters.
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